TERMS OF SERVICES | Close it

Logo

Are your extensions compatible with the latest Magento version?

Correct! All our extensions are compatible with Magento Community Edition 1.9.x version. Furthermore, most of them are also compatible with Magento Enterprise Edition.

Plumrocket Inc is working on Magento 2.0 extensions and we should be updating them shortly as well.

For more information please check the Magento Compatibility section located on every extension page.

Magento Compatibility



Still Need Help?